PDA

View Full Version : i got a sever error"requires PHP 5.3 to be installed". Isn't that PHP should be 5.2+?


huihuang yu
10-31-2011, 07:56 AM
Hi everyone,

i am new to vivvo, but our company really want to have a try on this product.

i was quite confident after i had looked on installation guide. However, right now, i am really really frustrated. anyone please help me out. we would really really appreciated.

i followed the installation guide step by step; everything looks good before i running the installer; i checked the system requirement and get "• Passed - Fully supported by the server " ; i changed the permission as required; But when i open the install page and waited for 10 second. i was told i need to install ionCube PHP Loader ioncube_loader_lin_5.2.so....

So, i went to the "http://www.ioncube.com/loaders.php" and download the right file for my vps server(freebsd 6.4 i368) and then installed it. After i did some work, i got a page say "The ionCube Loader version 4.0.10 for PHP 5.2 is already installed and encoded files should run without problems." I think it means i have successfully installed the ioncube loader right??

So, i started to run the installer again. unfortunately, after waiting for 10 seconds. i got another error: "Server Error....HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request." i became worried...

i went to the vivvo site, checked everywhere. i could not find any solution.
Then i realized i can open the server error log. After i open the log file, i saw this 2 error message every time when i run the installer:
===============================================
[Mon Oct 31 05:47:22 2011] [error] [client 110.142.34.76] PHP Fatal error: <br>The file <b>/home/testing/www/localtoday.co/index.php</b> was encoded with the PHP 5.3 ionCube Encoder and requires PHP 5.3 to be installed. in Unknown on line 0
[Mon Oct 31 05:47:32 2011] [error] [client 110.142.34.76] PHP Fatal error: <br>The file <b>/home/testing/www/localtoday.co/installer/index.php</b> was encoded with the PHP 5.3 ionCube Encoder and requires PHP 5.3 to be installed. in Unknown on line 0, referer: http://localtoday.co/installer/
===============================================

Then i feel really confused. because it is said on system requirement that php version is 5.2+ ; could any body tell me why? and what is the issue? should i really need to upgrade the php version? would it solve the problem if i upgrade it to 5.3??? please help. :confused::confused::confused:

Micha
10-31-2011, 10:13 AM
On system requirements page it says that you need PHP 5.2 or greater.
http://www.vivvo.net/doc/installation-guide/system-requirements.html

PHP 5.2 - Your web server must have PHP 5.2 or greater. Your network administrator can download the latest version of PHP from http://www.php.net. PHP is extremely common though, and installed on virtually every webserver on Earth.

My advice would be to install PHP 5.3 and ionCube encoder for that version.

huihuang yu
11-02-2011, 12:12 AM
Thanks for helping.

But the php version on my server is PHP 5.2.17, which does equal to "PHP 5.2 or greater"; but why still have server error?

It is not easy for me to upgrade php to 5.3.
Because i have several other websites running on my server. If i upgrade to php5.3; It may bring some big issue to those websites.

is there any other solution? Otherwise, why do not vivvo change the system requirement to PHP5.3+??

:(

bobster65
11-02-2011, 08:30 PM
you don't need php5.3 to run the actual vivvo app, you need php5.3 to run the ION Cubed Demo Version because when they ION CUBED the DEMO version, they did so on their servers that are running php5.3 and the Ioncube encoder for 5.3. THAT is the only reason why you would need to be running php5.3.

They need to change their documentation on the Demo version stating that you must use php5.3 because of the Ioncube encoder version, but that the non ion cubed version will run just fine on 5.2+

OR they SHOULD actually create an instance with php5.2 and the Ioncube Encoder for 5.2 and swap them out.

huihuang yu
11-02-2011, 11:14 PM
:) Thanks upstairs' .

You make it very clear. I would come for you if next time i meat any issue again.
But i hope this wont happen:D

They had used the original installer finished the mission for me.

But here, i want to throw another doubt:

I think you guys all know after php5.3. mysqlnd is used to replace libmysql. It is said that it is a new and better option for php compare to the MySQL Client Library. Yesterday, when i upgrade php to 5.3+ on a testing PC(windows). i found the mysql Client API version all became to something like this:
"mysqlnd 5.0.7-dev - 091210 - $Revision: 304625 $"

However, it seems this client api does not support VIVVO? Because when i run the check for System Requirement. It got "• Failed - Not supported by the server (critical problem) "

Did you meet this issue if you are using php5.3+?
How to change the mysql client api to the MySQL Client Library?

can anybody explain this for me? i would much appreciate it.:)

huihuang yu
11-02-2011, 11:36 PM
one addition information:

I just ran "php -m" in cmd in windows, and found:
[PHP Modules]
Core
...
mysqlnd
...

however, in the php.ini file. i could not find any extension enable for mysqlnd.

Does anyone knows this ? Thanks

huihuang yu
11-03-2011, 10:39 PM
hi, where is everybody?

huihuang yu
11-13-2011, 10:39 PM
can anyone give some help about this?


:) Thanks upstairs' .

You make it very clear. I would come for you if next time i meat any issue again.
But i hope this wont happen:D

They had used the original installer finished the mission for me.

But here, i want to throw another doubt:

I think you guys all know after php5.3. mysqlnd is used to replace libmysql. It is said that it is a new and better option for php compare to the MySQL Client Library. Yesterday, when i upgrade php to 5.3+ on a testing PC(windows). i found the mysql Client API version all became to something like this:
"mysqlnd 5.0.7-dev - 091210 - $Revision: 304625 $"

However, it seems this client api does not support VIVVO? Because when i run the check for System Requirement. It got "• Failed - Not supported by the server (critical problem) "

Did you meet this issue if you are using php5.3+?
How to change the mysql client api to the MySQL Client Library?

can anybody explain this for me? i would much appreciate it.:)