PDA

View Full Version : Four FREE plugins released!


boccio
03-21-2008, 09:26 PM
We just released couple of more plug-ins, all of them completely free.

Sitemap plugin
http://www.vivvo.net/resources/downloads/Plug-ins/sitemap.html
You asked for this one, we did it :)

Video box
http://www.vivvo.net/resources/downloads/Plug-ins/video_box.html
This one is very important, and I recommend everyone with media streaming websites to check it out!

Geo-position
http://www.vivvo.net/resources/downloads/Plug-ins/geo_position.html
This will probably be the most underrated plugin of all four we released, however IMO one of most elegant plugins we have. Just check it out...

Image Browser
http://www.vivvo.net/resources/downloads/Plug-ins/image_browser.html
One more image gallery plug-in

I hope you'll enjoy our new plug-ins :)

RichII
03-21-2008, 10:08 PM
Fantastic! Thanks guys.
________
MARYJANE (http://maryjanes.info/)

mandini76
03-21-2008, 10:39 PM
awesome!

Is there any way to get individual captions with the image gallery?

thanks!!!

Micha
03-22-2008, 11:47 AM
awesome!

Is there any way to get individual captions with the image gallery?

thanks!!!

With this one no, but we are working on image gallery that will give you that option :)

apocan
03-22-2008, 01:54 PM
I couldnt install these plugins. When I click install button in the admin panel there appears blank page... what is the problem

utvara
03-24-2008, 10:33 AM
All you have to do is to unzip plug-in on your PS and upload the folder structure as is to your web site (directly to your VIVVO ROOT).

kaesar30
03-25-2008, 07:29 PM
I'm not able to install the plugins. I've unzip and upload to vivvo root with the folder structure. But when I tried to install SITEMAP, VIDEO BOX adn IMAGE BROWSER only appears a blank page.

If I try to install GEOPOSITION this error appears '
Fatal error: Cannot instantiate non-existent class: preferences_list in /home/casoabie/public_html/lib/vivvo/framework/configuration.class.php on line 144'
________
LOVE QUOTES DICUSSION (http://www.love-help.org/love-quotes/)

andy77
03-26-2008, 12:33 AM
Are you running 4.0.3 ?

kaesar30
03-26-2008, 01:10 AM
yes of course. Any idea of how can I solve this?
________
PLYMOUTH BELVEDERE SPECIFICATIONS (http://www.dodge-wiki.com/wiki/Plymouth_Belvedere)

Tani
03-26-2008, 05:08 AM
Hi
I have the same problem. When I click install I get a white blank page. I uploaded all the files using the folder scheme.

shketuljko
03-26-2008, 11:22 AM
I think that problem is related with version of Vivvo. If you use 4.0.1 or 4.0.2 or 4.0.3 beta or 4.0.3 beta2 version of Vivvo, plug-in will not work properly.

@Tani and @kaesar30
Could you provide me url of your web site?

kaesar30
03-26-2008, 05:59 PM
Hi,

That's the problem. I've 4.03 beta2 version. I'm installing the last version.

Best Regards
________
Glass Bowls (http://glassgallery.tumblr.com/glass-bowls)

apocan
03-26-2008, 07:55 PM
upload 4.03 beta2 english admin language file to your ftp. I had had the same problem but when I uploaded it it worked :)

Tani
03-26-2008, 11:25 PM
I am using 4.3 beta. I will try to install 4.3 and then I will let you know if I have any problem

apocan
03-27-2008, 09:22 AM
I installed all the plugins and it seems that they are working great for me :) really nice plugins.

but I want to ask question. can we do something for image gallery? for example I want to show the latest photos in index page as in category with small thumbnails. I tried copying the codes from tpl but it didnt work. their links were working but the images are not visible.

how can we do this?

kovacs
03-27-2008, 01:15 PM
I'd also be interested in the answer to that last question! :)

Tani
03-28-2008, 03:13 AM
I upgraded from 4.3 beta to 4.3 and image_browser works. I have a question
Can I make images to show bigger?
<a href="thumbnail.php?file={dir|fix_images_path}/{file.filename}&amp;size=article_large" rel="lightbox[roadtrip]">

Tani
03-28-2008, 07:14 PM
Does anyone has an answer for the question above

Ksenija
03-31-2008, 08:58 AM
Change width/height for "Article large image" in Administration -> Preferences -> Layout&modules -> Image size.

Tani
04-01-2008, 02:16 AM
If I change the Large Image size, that will effect my main page images. Can I create another folder and use that for images plug only?
Thanks for your input

apocan
04-01-2008, 11:59 AM
<a href="thumbnail.php?file={dir|fix_images_path}/{file.filename}&amp;size=1024" rel="lightbox[roadtrip]">

try this maybe it works :D

Tani
04-02-2008, 04:32 AM
didn't make any difference. It makes sense to work like that, but it doesn't. If one of the senior guys read this message, maybe they have an answer.

Thanks in advance

mandini76
04-02-2008, 07:54 AM
I installed everything and uploaded jpgs to public_html/files/images/

when I go to my site and type in www.mysite.com/images I get: 404 File Not Found

when I go to www.mysite.com/files/images I get: 403 Forbidden

When is it not recognizing the installation? I uninstalled it and reinstalled it successfully.

gyllingdk
04-02-2008, 11:07 PM
Great videomod...but HOW do I download it??
It says that I'm gonna be logged in to download, but now im confused - cause I AM logged in to this forum...do you need a seperate username/password to download?
I've bought vivvo a little year ago, but cant remember any passwords - only for forum
and It cant find my mail adress in db. What to do?

kovacs
04-03-2008, 07:26 AM
Send a support ticket, perhaps?

apocan
04-03-2008, 01:34 PM
Great videomod...but HOW do I download it??
It says that I'm gonna be logged in to download, but now im confused - cause I AM logged in to this forum...do you need a seperate username/password to download?
I've bought vivvo a little year ago, but cant remember any passwords - only for forum
and It cant find my mail adress in db. What to do?

its different from forum login. you should log in to resources section

http://www.vivvo.net/resources/login.php

rheaton
04-04-2008, 02:52 PM
The image gallery plug in does not work for me either.

It installs, I don't get the white screen others report. However it never shows up anywhere.

I am using the pro version and installed the latest patch. Still not luck. Thoughts?

boccio
04-04-2008, 03:21 PM
However it never shows up anywhere.

This particular plugin does not have web-interface, the purpose of ImageBrowser is to allow uploading images via FTP to folder(s) that will automatically show as galleries. You have readme.txt in plugin explaining usage:

1. Description

This plug-in will help you to show image browser on your Vivvo site. It takes images that you upload to your server and creates image browser that is accessible on http://www.example.com/images page. Using Lightbox gallery image will enlarge when user click on its preview.

(...)

4. Actions

Upload images via FTP to VIVVO_ROOT/files/images folder that is automatically created during installation. On the http://www.example.com/images, thumbnails are previewed and can be enlarged on a click. You can also create subfolder with images that will automatically create a link in navigation and a separate galery on the http://www.example.com/images/subfolder link.

rheaton
04-04-2008, 06:52 PM
Does this require mod_rewrite to be working on the server? It's the only reason I can think of why this isn't working for me.

No attempts to view the images work. I have set it up correctly, uploaded a subfolder in the ..files/images folder and when I attempt to go to digitalbackspin.com/images/lotro all it generates is a 404. I'm assuming the mod_rewrite is required to tell it where "images" really is?

mandini76
04-05-2008, 10:17 AM
It didn't work for me until I FINALLY got mod_rewrite fixed. Then it showed up.

webbyradio
04-10-2008, 04:54 PM
I have a question about Video Box, has anyone had any luck getting it to work? Will it only accept mp4, flv and mov? I added the following formats in the video_field.xml: mpg, wmv and avi. I especially need wmvm because that's the native format our station uses on your station website and then the movie is encoded to .flv. Anyway suggestions? thanks...

afaaro
04-11-2008, 07:55 PM
It didn't work for me until I FINALLY got mod_rewrite fixed. Then it showed up.

Can you please give me the step you have taken, very appreciated.

mandini76
04-17-2008, 05:54 AM
I didn't do anything - it was the tech support people who had to fix something to get mod_rewrite working. The problem involved the .htaccess file I believe. It might not have been copied over properly.

Elton
04-23-2008, 04:39 PM
I've installed the video mod, but following the instructions, I get to here:

- Go to your Administration - Categories and select a category that will contain articles with video files attached. Set the non_equal_video.tpl for 'Custom layout' and two_column_video.tpl for 'Article custom layout'.

These options simply aren't there in the drop down box for me :(

Any ideas?

Ksenija
04-24-2008, 11:04 AM
Maybe you should try to copy template files manually from /plugins/video_box/templates/ to VIVVO_ROOT/templates/TPL_FOLDER/.

mandini76
06-07-2008, 04:08 AM
How soon we will see an update to this that will allow us to give captions to the images?

Right now it's pretty useless to me if I can't caption the photos...

thanks!

alienseeker
08-31-2008, 11:18 AM
Have you considered making Image Browser so that an image caption can be added to each image?

I like the plugin, but I am need of being able to add an image caption to each image to provide further details to my readers about the picture they are looking at and/or image credit to who sent the image.

Don

akash210
03-10-2009, 06:28 PM
Are you guys still looking to use this plugin with caption enabled? I've made a nifty little hack inside the plugin that'll allow you to do just that. :)

Let me know if you're interested.

Edit: But I'm having a bit of a hard time making the IPod box work properly. If I create two levels of subdirectory under one main directory, the little navigation menu (>>) that lets you slide to the right doesn't work. It has specifically to do with the file box_ipod_folders.tpl. On line 42 the code <vte:if test="{file.has_subfolders}"> is causing the problem. I know because when I remove the if statement all the >> reappear. Should have been something like {dir.has_subfolders} I suppose. I'm not sure though.

Anyone?

kreativostudio
03-11-2009, 07:41 PM
Sure we are still interested in getting captions enabled, can you please share your modification?

Thanks in advance

akash210
03-12-2009, 11:25 AM
Let me warn you from the offset that it's a very "dirty" hack and that you'll be using the filename as the caption. If you don't like this method already, just don't use it.

So basically lightbox allows you to insert a caption by using the title="your caption here" attribute. But this would also print out the file extension. So if you had a file named Steven Gerrard.jpg, it wouldn't print Steven Gerrard but the whole filename as the caption, i.e. Steven Gerrard.jpg. To avoid that, create the following function in ROOT/plugins/image_browser/image_browser_url_handler.php at the end of the file (just before ?>).

function filename_without_extension($filename){
$filename_no_ext = substr($filename, 0, -4);
return $filename_no_ext;
}

Then in ROOT/templates/YOUR TEMPLATE/plugin/image_browser.tpl, around line 32, replace
<a href="thumbnail.php?file={dir|fix_images_path}/{file.filename}&amp;size=article_large" rel="lightbox[roadtrip]">

with this one:
<a href="thumbnail.php?file={dir|fix_images_path}/{file.filename}&amp;size=article_large" rel="lightbox[roadtrip]" title="{file.filename|filename_without_extension}">

There you go. :)

krcko
03-12-2009, 02:35 PM
you could do that in vte, without a need of new php function:

{file.filename|preg_replace:'|\.[^.]+$|',''}

akash210
03-13-2009, 01:23 PM
you could do that in vte, without a need of new php function:

{file.filename|preg_replace:'|\.[^.]+$|',''}


Yes, you would think so. But unfortunately it doesn't work. Maybe there's a problem with your expression?

Anyway, can you help me with the IPOD box? It's not working properly (see my post on page 4 of this thread).

Thanks.

krcko
03-13-2009, 01:59 PM
sorry, I wasn't test the code I gave you, this one works:

{file.filename|preg_replace:'/\.[^.]+$/',''}


I'll take a look at iPod box if I find some spare time today...

theMezz
03-17-2009, 07:32 PM
so we have no new Image Browsers/Gallery browsers????

vanhire
03-18-2009, 04:48 PM
Hi there can someone please tell me how to get the Image Browser plugin work i cant see a manual but just a quick post will help.

thanks in advance